MobaXterm最新版破解

kali
2018-08-09 / 0 评论 / 121,631 阅读 / 正在检测是否收录...

MobaXterm是一款非常优秀的远程管理软件,支持SSH、Telnet、Rsh、Xdmcp、RDP、VNC、FTP、SFTP、Serial、File等各种协议,可以让你非常高效的管理你的服务器。
本来是想支持一波正版的,结果一看价格69美金有木有啊!!!高昂的价格让我等穷人望而却步。。。所以就对它进行了破解。。。咳咳。。能支持正版的同学还是支持正版,这个软件对于69美金的定位稍微有点高,但却很值!!

破解过程

采用内存破解方式。因为软件有自己的签名证书,为了不破坏证书,所以采用内存破解。

软件并没有加密。。。
破解的过程中参考了 https://www.52pojie.cn/thread-704974-1-1.html
原帖中作者采用了DLL劫持的方式实现不破坏证书。

我本来也是想通过劫持DLL实现,奈何在Win10上面不行??可能是我写的DLL有问题。。

后来写了启动器,一样实现破解且不破坏证书。

启动器代码(易语言)

程序使用了精易模块,易语言5.8编译即用。
源码下载地址:79
编译好的下载地址:82
解压密码:www.jindashen.cn
如果出现报毒属于正常现象,易语言嘛。。。

.版本 2
.支持库 spec
.支持库 dult
.支持库 iext

.程序集 窗口程序集_启动窗口
.程序集变量 PID, 整数型
.程序集变量 结果数组, 整数型, , "1"
.程序集变量 下标, 整数型
.程序集变量 成功次数, 整数型
.程序集变量 失败次数, 整数型
.程序集变量 搜索结果数量, 整数型

.子程序 __启动窗口_创建完毕

PID = 进程_创建 (“MobaXterm.exe”)
.如果真 (PID = 0)
    信息框 (“启动失败”, 0, , )
.如果真结束

延迟 (2000)
破解 ()

.子程序 破解

内存.搜索 (PID, 十六进制到字节集 (“33 D2 89 90 9C 0C 00 00”), 结果数组)

搜索结果数量 = 取数组成员数 (结果数组)

.如果真 (搜索结果数量 = 0)
    信息框 (“该补丁已经失效,或者已经打上补丁!”, 0, , )
    返回 ()
.如果真结束

状态条1.置文本 (0, “需要补丁:” + 到文本 (搜索结果数量) + “ 次”)

.计次循环首 (搜索结果数量, 下标)
    状态条1.置文本 (1, “当前补丁:” + 到文本 (下标) + “ 次”)
    .如果 (内存.写字节集 (PID, 结果数组 [下标], 十六进制到字节集 (“C6 80 9C 0C 00 00 01 90”)))
        成功次数 = 成功次数 + 1
        状态条1.置文本 (2, “成功补丁:” + 到文本 (成功次数) + “ 次”)

    .否则
        失败次数 = 失败次数 + 1
        状态条1.置文本 (3, “补丁失败:” + 到文本 (失败次数) + “ 次”)
    .如果结束
    延迟 (100)
.计次循环尾 ()
.如果 (成功次数 = 搜索结果数量)
    信息框 (“破解完毕”, 0, , )
    结束 ()
.否则
    信息框 (“破解失败”, 0, , )
.如果结束

.子程序 _按钮1_被单击

破解 ()

效果图

1.jpg
破解成功后会提示

2.jpg
显示已经注册(虽然状态栏仍然显示未注册)

0

评论 (0)

取消